View Single Post
  #5642  
Old 10-11-2018, 04:12 PM
evildre evildre is offline
i liek turtles
 
Join Date: Aug 2008
Location: Lombard, IL
Posts: 3,073
Default

Quote:
Originally Posted by runt View Post
Yeah, my file server is using 8GB of RAM but it does have ZFS.
I hadn't used ZFS in over a year, but I had to give it a go again.

I threw Windows Server 2016 Datacenter Edition on a machine very similar to my own -- same CPU, same amount of RAM, but it has a 500GB SSD boot volume, two 250GB SSDs attached to the built-in 6Gb SATA ports, and twenty 8TB hard disks attached to a 24-port PCI Express HBA. After a bit of struggle I managed to get a multi-redundant Storage Space running, but after the first 40 or so GB of data transfer performance straight-up tanked. Tried it out using a tiered mirror as well (i.e. from the Server Manager GUI rather than PowerShell), but that behaved the same. So, I threw Debian + ZFS on the same hardware, created a raidz2 across the twenty 8TB disks, and put the two 250GB SSDs in front of that as cache. Then I put a Windows Server 2016 Standard VM on it, with its secondary storage volume on the ZFS, and tried the same thing ... in the time it took to copy 60 GB with Windows on bare metal, the VM (with 4 cores and 16GB of RAM) has copied almost 700 GB.

So ... yes, ZFS is old. No, it wasn't written for Debian. But yes, it's fast as shit on that hardware, and Storage Spaces (whether Direct or not) on that hardware is shameful.
__________________
Emerald: i7-4930k @stock, Thermaltake Water 3.0 240 RGB, Gigabyte GA-X79-UP4, 64GB Crucial DDR3, Asus GeForce GTX 1070 TURBO 8GB, 250GB Samsung 850 Evo SSD, 2x 6TB WD Red RAID 1, Thermaltake Core V51 Riing Edition, Corsair AX750

noisybox: i7-2600k @stock, Corsair H50, Asrock Z68 Extreme4 Gen3, 32GB Crucial Ballistix Sport, 250GB Samsung 850 Evo SSD, 500GB Samsung 840 Pro SSD, 2x 8TB WD Red RAID 1, Corsair Carbide 200R, 6x Thermaltake 120mm fans, SeaSonic X650 SS-650KM3, Debian 9.5 + Proxmox VE
Reply With Quote